Incident Notice – All JTL-Cloud Services Affected
Resolved
Oct 29 at 10:01pm CET
All issues are resolved and the JTL-Cloud Platform is fully available again. Thank you for your patience
Affected services
Updated
Oct 29 at 09:00pm CET
We are seeing initial signs of recovery across JTL-Cloud services as Microsoft continues to restore affected Azure infrastructure. Some systems are becoming available again, but overall performance remains degraded.
We are closely monitoring the ongoing recovery process and will provide further updates as stability improves.
Affected services
Updated
Oct 29 at 08:36pm CET
According to Microsoft, full recovery is expected within the next four hours (by 23:20 UTC on 29 October 2025). We continue to monitor the situation closely and will provide another update within the next two hours or sooner if significant progress occurs.
Affected services
Created
Oct 29 at 05:18pm CET
We are currently experiencing a global issue with Microsoft Azure which is causing all JTL-Cloud services to be unavailable. We are monitoring the situation closely and will provide updates as soon as they become available. Thank you for your patience.
Affected services